Datto SaaS Protection - Microsoft Throttling For M365 Teams Services In Canada Region
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 20:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2024 - 12:35 UTC
Identified
We are currently aware of a problem where Datto SaaS Protection users can experience M365 Teams backup failures due to Microsoft throttling in the Canadian region.



Our Engineering team has identified the problem and is working towards a resolution.




Subscribe to Datto SaaS Protection on the Status Page for up to date information.



You can monitor the current status of this issue at https://status.datto.com/
Posted Mar 25, 2024 - 14:19 UTC
This incident affected: Datto SaaS Protection (SaaS Protection Backups).