Login Services
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 16:26 UTC
Monitoring
Login issues have been resolved but we are closely monitoring the situation
Posted Dec 05, 2019 - 15:56 UTC
Investigating
We are currently investigating an issue with logging into Partner Portal. Our engineering team is urgently looking into the issue and will update here.
Posted Dec 05, 2019 - 14:54 UTC
This incident affected: Partner Portal.