Support Phones Outage
Incident Report for Datto
Resolved
Our engineering team has been closely monitoring this problem. The service has been deemed stable. We are now marking this incident as resolved. If you are still experiencing difficulties, please reach out to our Support Team at 877-455-6015. A post-mortem is forthcoming. Thank you for your patience.
Posted 3 months ago. Feb 21, 2019 - 13:48 UTC
Investigating
Support Phones.partial
Posted 3 months ago. Feb 21, 2019 - 13:28 UTC
This incident affected: Support Phones.