PSA - AE2 & AW2 - API users unable to connect / Error "Server returned HTTP Response code 503"
Incident Report for Datto
Postmortem

On June 11th 2022 at 14:01 UTC, Autotask PSA partners in zones AE2 & AW2 experienced a service interruption.

This caused an application pool for the first numbered API server in both the AE2 and AW2 zones stopped, halting jobs on both of those hosts. Other hosts within the zone continued to process requests, but if a client had established a connection with either of the troubled hosts, they would encounter errors.  These hosts should have been pulled out of the load balancing pool, since one or more of their application pools had stopped, but were not.   

Our Engineering team deployed a fix to correct the problem on June 11th 2022 at 17:43 UTC.

We are investigating why the hosts were not pulled out of the load balancing environment when their application pools had stopped processing work.

Posted Aug 03, 2022 - 15:37 UTC

Resolved
This incident has been resolved.
Posted Jun 11, 2022 - 18:24 UTC
Monitoring
A fix has been implemented and we are monitoring results.
Posted Jun 11, 2022 - 18:12 UTC
Investigating
Our teams are currently investigating API users being unable to connect / Error "Server returned HTTP Response code 503" in our AE2 & AW2 zones.

Thank you for your patience!
Posted Jun 11, 2022 - 17:44 UTC
This incident affected: Autotask PSA (America East 2, America West 2).