Backupify SaaS Console Login - Partial Outage
Incident Report for Datto
Postmortem

This outage impacted partners backing up O365 and was caused by human error in the improper execution of a maintenance script. We have examined and corrected processes around the script itself and have begun a full review of all similar scripts to ensure this issue will not be repeated. We apologize for the inconvenience.

Posted Dec 20, 2018 - 20:03 UTC

Resolved
This issue has been resolved. A post-mortem will be added within 24-48 hours.
Posted Dec 19, 2018 - 13:18 UTC
Investigating
We are currently investigating an issue where a subset of our partners are seeing issues logging into the Saas Protection console. We apologize for any inconvenience and will post updates here.
Posted Dec 19, 2018 - 12:57 UTC
This incident affected: Datto SaaS Protection (SaaS Protection Console Login).