Datto RMM - Concord - Intermittent slowness and failure to load pages in the New UI
Incident Report for Datto
Postmortem

On 16th November 2023 around 15:00 UTC, Datto RMM partners on the Concord (US East) platform experienced a service incident that resulted in slowness when navigating in the product. Users may have also encountered an error when loading pages or during the login procedure as a result of timeouts.

The incident was resolved at 16:12 UTC on the same day.

The reason for this incident was the high resource utilization of the main database serving data to the application. The root cause of the issue was determined to be low performing procedures taking a long time to run when accessing the database, and consuming resources in the process.

The issue was mitigated by scaling the database, and stopping the procedures. Action was subsequently taken to improve the performance of these procedures in the interest of minimizing the likelihood of the issue re-occurring for the same reason in the future.

Posted Dec 13, 2023 - 12:40 UTC

Resolved
The R&D Teams have been addressing issues with page load times on the Concord platform.

We apologise for the inconvenience!
Posted Nov 16, 2023 - 15:00 UTC