Datto RMM-Unable to download Windows Agent Installer
Incident Report for Datto
Resolved
This incident is now resolved. You should be able to download Datto RMM Windows Agent Installer. If you continue to see an issue, please get in touch with our Datto RMM Support team.
Posted Jan 22, 2020 - 00:33 UTC
Monitoring
Digicert have confirmed that a fix has been implemented.

https://websitesecurity.status.digicert.com/

We have verified that the Windows Agent installer can now be downloaded without any issue through out our all platforms. We will still continue to monitor this from our end.

If you are still receiving errors, please get in touch with our RMM Support team.
Posted Jan 22, 2020 - 00:09 UTC
Identified
The issue has been identified to be related to an issue that Digicert is currently experiencing. We are currently waiting for them to resolve the issue. Once we have an update from Digicert, we will update the status page further.

https://websitesecurity.status.digicert.com/
Posted Jan 21, 2020 - 22:27 UTC
Investigating
We are currently investigating an issue where you are unable to download windows agent installer in Datto RMM.

Following error message is received:

Agent build returned error code 143
Posted Jan 21, 2020 - 22:19 UTC
This incident affected: Datto RMM (Pinotage (EU1), Merlot (EU2), Zinfandel (US West), Concord (US East), Syrah (APAC)).