BCDR Status page in the Partner Portal can fail to load successfully
Incident Report for Datto
Resolved
This incident has been resolved.
Posted May 20, 2022 - 16:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2022 - 13:25 UTC
Investigating
We are currently aware of a problem where the BCDR Status Page in the Partner Portal can fail to load.

Our Engineering team is currently investigating this issue.

Currently, we do not have an ETA on when a fix will be available.

You can monitor the current status of this issue at https://status.datto.com/
Posted May 20, 2022 - 13:23 UTC
This incident affected: Partner Portal.