PSA - LR Zone (ww1) - Service unavailable - Resolved
Incident Report for Datto
Postmortem

On 3-September-2021 at 14:40 UTC, Autotask PSA Partners on the Limited Release (ww1) zone experienced a service interruption which caused the application to be inaccessible.

The root cause for this service interruption was a refresh process initiated by our team that resulted in the web servers serving the zone to lose connection to our load balancers. This resulted in the web servers not receiving any external traffic making the service unavailable.

The issue was resolved at 14:55 UTC on the same day after the refresh completed.

In order to prevent this issue from happening again, the team performing the refresh has implemented changes to their process, and the LR zone infrastructure will be updated to make the webserver - load balancer communication more robust.

We have also confirmed that none of the other zones had a similar architectural setup, therefore they are not susceptible to the same issue.

Posted Sep 07, 2021 - 13:38 UTC

Resolved
This incident has been resolved.
Posted Sep 06, 2021 - 09:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2021 - 15:09 UTC
Identified
Our teams are currently working to resolve the service unavailable error on the Limited Release Zone for Autotask PSA.

An update will be posted here within 30 minutes with the status of this investigation.

Thank you for your patience!
Posted Sep 03, 2021 - 14:49 UTC
This incident affected: Autotask PSA (Limited Release).