Datto SaaS Protection - Seat Management Failures For M365 Teams and Exchange Services
Incident Report for Datto
Postmortem

On January 30th 2024, Datto SaaS Protection partners experienced issues caused by inconsistencies between Seat Management and the live M365/Google environments, leading to backup failures.

 

The root cause for this service interruption was caused by an incomplete retrieval of undeleted seats.

 

Our Engineering team deployed a fix to correct the problem on February 2nd 2024.

Posted Feb 06, 2024 - 14:02 UTC

Resolved
This incident has been resolved.
Posted Feb 05, 2024 - 20:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2024 - 14:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 01, 2024 - 21:00 UTC
Investigating
We are currently aware of a problem where Datto SaaS Protection can experience Seat Management failures for M365 Teams and Exchange services.,



Our Engineering team is investigating this issue.



You can monitor the current status of this issue at https://status.datto.com/
Posted Jan 30, 2024 - 15:13 UTC
This incident affected: Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Seat Management).