Datto RMM - Concord (US East) - Device Disconnection and Error Messages
Incident Report for Datto
Postmortem

Start date/time: 16:51 November 23rd, 2020

End date/time: 17:06 November 23rd, 2020

Platform: Concord Direct cause: Database connectivity failure.

User Impact: Devices were disconnected as their sessions became invalid. During the database failover users will have experienced errors in the web portal and agent browser. These errors will have persisted for longest in the new UI as the DB reader was unavailable until the issue was resolved.

Underlying cause: A hardware failure in the database primary causing instances to lose connection. Steps taken to restore service: The database primary was failed over to a standby instance and the reader taken offline for a few minutes while the issue was resolved.

Posted Nov 23, 2020 - 19:51 UTC

Resolved
Start date/time: 16:51 November 23rd, 2020


End date/time: 17:06 November 23rd, 2020


Platform: Concord

Direct cause: Database connectivity failure.


User Impact: Devices were disconnected as their sessions became invalid. During the database failover users will have experienced errors in the web portal and agent browser. These errors will have persisted for longest in the new UI as the DB reader was unavailable until the issue was resolved.


Underlying cause: A hardware failure in the database primary causing instances to lose connection.


Steps taken to restore service: The database primary was failed over to a standby instance and the reader taken offline for a few minutes while the issue was resolved.
Posted Nov 23, 2020 - 16:30 UTC