Datto SaaS / Backupify Technical Support Phone Line (1-877-400-7227) (05/08/20)
Incident Report for Datto
Resolved
This incident has been resolved.
Posted May 11, 2020 - 13:53 UTC
Update
We are continuing to monitor for any further issues.
Posted May 11, 2020 - 13:53 UTC
Monitoring
The issue has been resolved and phone calls should connect as expected. We will be monitoring for the next hour to ensure this is fully resolved.
Posted May 08, 2020 - 19:29 UTC
Identified
We've identified an issue affecting callers dialing 1-877-400-7227 that may result in dropped calls and dead air. Our team is working on resolving this as soon as possible.
Posted May 08, 2020 - 17:52 UTC
This incident affected: Datto Phones (Support Phones).