PSA - UK, UK2, LON, UKLR - Platform Inaccessible
Incident Report for Datto
Postmortem

On November 8, 2023, a networking services failure occurred in our UK operation, causing Autotask servers to become unavailable for a brief period of time. Our engineering team had responded and corrected the issue by restarting Autotask application services, and access was restored within one hour.

Posted Nov 28, 2023 - 19:44 UTC

Resolved
This incident as been resolved.
Posted Nov 08, 2023 - 15:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2023 - 14:37 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 08, 2023 - 14:22 UTC
Investigating
We are currently investigating the Autotask PSA platforms being inaccessible.

We apologize for any inconvenience caused.
Posted Nov 08, 2023 - 13:56 UTC
This incident affected: Autotask PSA (UK Limited Release (United Kingdom), UK (United Kingdom), UK 2 (United Kingdom)).