PSA - AU - Outbound notifications failing or significant delays
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 17:36 UTC
Investigating
Our teams are currently investigating outbound notifications failing or significant delays from PSA on AU Zone.

Thank you for your patience!
Posted Mar 14, 2023 - 04:39 UTC
This incident affected: Autotask PSA (Australia / New Zealand).