PSA - America West - 503 Errors - while navigating the system - under investigation
Incident Report for Datto
Postmortem

Start and End Date/Time (UTC):

21:45 October 7th, 2019 - 00:29 October 8th, 2019

Zone(s) Affected:

America West

User Impact:

Reports of 503 Errors while navigating PSA

Underlying Cause:

After further investigation, it was determined that critical services for this zone were not communicating with each other after automated restarts. The automated restarts were initiated as part of our routine, regular updates of critical security patches which are released by our Operating Systems vendor.

Steps Taken:

The methodology we utilize for these critical monthly updates has been in place for years with minimal incidents. We are working internally to determine how to better prevent this issue from occurring again in the future.

Posted 11 days ago. Oct 11, 2019 - 14:33 UTC

Resolved
This incident has been resolved.
Posted 17 days ago. Oct 06, 2019 - 00:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 17 days ago. Oct 06, 2019 - 00:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 17 days ago. Oct 06, 2019 - 00:37 UTC
Update
We are continuing to investigate this issue.
Posted 17 days ago. Oct 06, 2019 - 00:30 UTC
Investigating
Our teams are currently investigating reports of 503 errors on the America West platform. An update will be posted here within 30 minutes with the status of this investigation.

Thank you for your patience!
Posted 17 days ago. Oct 06, 2019 - 00:06 UTC
This incident affected: Autotask PSA (America West, America West 2).