Datto Workplace and Datto File Protection - US Region - Inability to Log into Manager
Incident Report for Datto
Postmortem

On 7th October 2021 at 17:28 UTC, Datto Workplace and Datto File Protection Partners in the United States region experienced a service interruption which caused the Datto Workplace and Datto File Protection web interfaces to perform slowly and then become temporarily inaccessible.  

This included Datto Workplace and Datto File Protection Manager and Online End-User Portals in the region as well. 

The root cause for this service interruption was identified to be a higher than usual volume of requests towards our web servers behind the web interfaces of Datto Workplace and Datto File Protection.  This has caused a low memory state which resulted in increased slowness on the user interface due to requests being queued to be processed. 

It was identified that an unscheduled configuration change was required to resolve this issue, and this necessitated taking the servers offline temporarily. 

The Engineering team applied the configuration change at 20:38 UTC and restored the service to fully operational status.

Posted Oct 11, 2021 - 18:27 UTC

Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 20:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2021 - 18:08 UTC
Investigating
Our teams are currently investigating 504 errors, when logging into the Manager for Datto Workplace and File Protection on all cells. An update will be posted here within 30 minutes with the status of this investigation.

Thank you for your patience!
Posted Oct 07, 2021 - 17:28 UTC
This incident affected: Datto File Protection (US8, EU10, EU11, EU12, AU14, CA13, US9) and Datto Workplace (AU5, CA3, EU2, EU4, EU7, EU16, US1, US6, US15).