Datto Portal - Issues accessing Kaseya Store from Datto Partner Portal
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 17:56 UTC
Identified
The problem has been identified. Support has been provided further workarounds to assist with a resolution. Please submit a support case if you are experiencing this issue and our team will be able to assist.
Posted Apr 27, 2023 - 15:15 UTC
Investigating
We are investigating an issue affecting a small percentage of Kaseya customers that may result in a '500 HTTP Error' when attempting to access the Kaseya Store / Billing Portal from the Datto Partner Portal.

The Kaseya Store / Billing Portal is accessible by:

Using a KaseyaOne account, you can access the Kaseya Store / Billing Portal from KaseyaOne to make store purchases; view/download invoices, pay bills and update payment methods.

If you don't have a KaseyaOne account, we can create your account and you will be able to access Kaseya Store / Billing Portal to make store purchases; view/download invoices, pay bills and update payment methods.

Updates will be posted on status.datto.com as we continue to work towards resolving this error condition.
Posted Apr 20, 2023 - 14:03 UTC
This incident affected: Datto Store (Product Selector, Check Out, Make a Payment, Subscription Management, Purchase History).