Datto SaaS Protection - Onboarding Errors
Incident Report for Datto
Resolved
Engineering has successfully created a fix and confirmed that both the onboarding and unintentional archiving issues related to M365 licenses have been resolved.

Please contact Support if you are still experiencing issues related to this outage.
Posted Mar 30, 2021 - 20:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2021 - 18:08 UTC
Update
We are continuing to work with Microsoft on a fix at this time.
Posted Mar 23, 2021 - 14:21 UTC
Update
We are continuing to work with Microsoft on a fix at this time.
Posted Mar 22, 2021 - 13:04 UTC
Update
We are continuing to work with Microsoft on a fix at this time.
Posted Mar 19, 2021 - 16:54 UTC
Identified
SaaS Protection is currently experiencing a service interruption with onboarding new M365 licenses due to intermittent connection issues with Microsoft's API . This is due to Microsoft currently experiencing an interruption on their side. As a result of the API connection issues, we have also received reports that some user services are becoming archived unintentionally.

Our Engineering team has identified the problem and is actively working with Microsoft on a resolution. An update will be provided as soon as possible regarding an ETA for onboarding to be accessible again. All other aspects of SaaS Protection (including Backup, Restore, and Export) are fully operational.
Posted Mar 19, 2021 - 13:46 UTC
This incident affected: Datto SaaS Protection and Backupify (Backupify SaaS Protection Client Onboarding).