PSA - English Europe - 2019.1.5 Minor Release
Scheduled for Jun 19, 18:00 - 21:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted 6 days ago. Jun 13, 2019 - 18:45 UTC
Scheduled
Maintenance Type: PSA Minor Release

Release Number: 2019.1.5

Purpose: Releasing fixes to some customer reported Defects.

Impact: None

Link to the list of Tickets fixed with this release:
https://success.autotask.net/t5/Professional-Services-Automation/PSA-Minor-Release-Info/m-p/51273
Posted 6 days ago. Jun 13, 2019 - 18:44 UTC
This scheduled maintenance affects: Autotask PSA (UK (United Kingdom), UK 2 (United Kingdom), UK Limited Release (United Kingdom), EU1 (English Europe and Asia)).