Datto SaaS Protection and Backupify Navigation Outage 02/11/2020
Incident Report for Datto
Resolved
Our Engineering team has resolved this problem.
Posted Feb 11, 2020 - 20:26 UTC
Investigating
SaaS Protection/Backupify is currently experiencing intermittent page-load issues when navigating the Application. Multiple On-Call resources are investigating the problem and working towards a solution. No ETA is available for a resolution at the moment. Updates will be posted as they become available.
Posted Feb 11, 2020 - 16:41 UTC
This incident affected: Datto SaaS Protection and Backupify (Backupify Backups, Backupify SaaS Console Login).