Endpoint Backup & Endpoint Backup for PCs - Endpoint Backup status page may fail to display agents and users may experience failures during agent registration
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jul 12, 2024 - 14:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2024 - 13:05 UTC
Identified
We are aware of a problem where the Endpoint Backup status page may fail to display agents and users may experience failures during agent registration.

The Kaseya R&D Team has identified the issue and is working towards a resolution.
Posted Jun 21, 2024 - 17:13 UTC
This incident affected: Endpoint Backup (Agent Registration), Datto Endpoint Backup for PC (Agent Registration), and Partner Portal.