Backupify SaaS Console Login Outage
Incident Report for Datto
Postmortem

We encountered a large volume of requests impacting database performance. This resulted in login issues for some customers. As a result of this event, we are improving monitoring to detect issues like this before they become a problem in the future. We apologize for any inconvenience this caused.

Posted 7 months ago. Apr 08, 2019 - 15:36 UTC

Resolved
Our engineering team has been closely monitoring this problem. The service has been deemed stable. We are now marking this incident as resolved. If you are still experiencing difficulties, please reach out to our Support Team at 877-455-6015. A post-mortem is forthcoming. Thank you for your patience.
Posted 7 months ago. Apr 05, 2019 - 17:48 UTC
Update
We are investigating a slow response from our authentication servers impacting the performance or the ability for some users to log into the application. We are actively working to resolve the situation and will provide updates as they become available.
Posted 7 months ago. Apr 05, 2019 - 17:00 UTC
Investigating
Backupify SaaS Console Login.partial
Posted 7 months ago. Apr 05, 2019 - 14:27 UTC
This incident affected: Datto SaaS Protection and Backupify (Backupify SaaS Console Login).