EMEA support phones experiencing problems.
Incident Report for Datto
Resolved
This issue has been resolved.
Posted 14 days ago. Sep 05, 2019 - 10:07 UTC
Investigating
We are currently experiencing a problem routing calls for the EMEA support number. Please use our US support number +1.833.832.4780 as a backup.
Posted 14 days ago. Sep 05, 2019 - 09:27 UTC
This incident affected: Support Phones.