RMM - Zinfandel - 503 Error When Logging In
Incident Report for Datto
Postmortem

On January 11th, 2022 at 15:19 UTC, Datto Partners on the Pinotage platform experienced a service interruption which caused 503 errors to appear upon login.

The root cause for this service interruption was identified to be rate limiting for the requests. Datto RMM utilizes Partner Portal to authorize logins. The Zinfandel platform’s backend IP addresses were missing from an allow list to bypass Partner Portal rate limiting. This resulted in Zinfandel becoming rate limited and preventing login attempts.

The appropriate backend IP addresses for the Zinfandel platform was added to the applicable allow list. The service was restored by January 11th, 2021 16:20 UTC.

Posted Jan 20, 2022 - 11:44 UTC

Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 16:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2022 - 15:42 UTC
Investigating
Our teams are currently investigating 503 errors, when logging on for Datto RMM on Zinfandel. An update will be posted here within 30 minutes with the status of this investigation.

Thank you for your patience!
Posted Jan 11, 2022 - 15:23 UTC
This incident affected: Datto RMM (Zinfandel (US West)).