Datto Partner Portal - Some pages in the portal may fail to load with a 500 error
Incident Report for Datto
Postmortem

On 8th November at 7:25am EST, Datto On-Prem, Datto Backup for Microsoft Azure, Datto Endpoint Backup for Servers, and Datto Endpoint Backup for PCs partners experienced a service interruption which caused the Recovery Launchpad and Device Status pages in the partner portal to be unavailable.   

The root cause for this service interruption was identified to be a cloud service outage caused by heavy loads on storage servers. 

Our Engineering team deployed a fix to mitigate the problem on 8th November at 10am EST. The heavy load on the storage servers has been addressed to get us to a stable permanent fix.

Posted Nov 13, 2023 - 19:10 UTC

Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 18:24 UTC
Monitoring
We have identified the root-cause of this issue and a fix has been implemented. At this time all pages in the partner portal should load successfully.
Posted Nov 08, 2023 - 21:07 UTC
Investigating
We are currently investigating an issue where some pages in the Datto Partner Portal fail to load with a 500 error.
Posted Nov 08, 2023 - 15:31 UTC
This incident affected: Partner Portal.