PSA - UK2 Zone (WW16) - long loading time - Under Investigation
Incident Report for Datto
Resolved
This incident has been resolved.
Posted May 04, 2021 - 12:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2021 - 10:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 04, 2021 - 10:05 UTC
Investigating
Our teams are currently investigating reports of long loading times for PSA on the UK2/ww16 zone. Updates will be posted here as we progress with the status of this investigation.

Thank you for your patience!
Posted May 04, 2021 - 09:33 UTC
This incident affected: Autotask PSA (UK 2 (United Kingdom)).