PSA - CLEP email to ticket creation delays - Under Investigation
Incident Report for Datto
Postmortem

Start and End Date/Time (UTC):

07:50 October 9th, 2019 - 09:49 October 9th, 2019

Zone(s) Affected:

DE1, EU1

User Impact:

Incoming email process was delayed

Underlying Cause:

Upon further investigation we determined that a critical service for mail processing had stopped whenever it tried to process a particular message.

Steps Taken:

Removing that message allowed for the remaining queued messages to be processed. While trying to reproduce the root cause in a lab environment using the original malformed message, our engineers were unable to cause mail flow to stop. We have continued to monitor mail processing for the past 14 days and the issue has not returned, and are working to improve filtering mechanisms in order to bypass messages with apparently malformed header information.

Posted Oct 24, 2019 - 13:19 UTC

Resolved
This incident has been resolved.

We know how important the PSA application is to your business and apologize for the impact this issue had.
Posted Oct 09, 2019 - 10:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Please kindly note that all emails will be processed, however, it may take some time as we are working through the backlog.
Posted Oct 09, 2019 - 10:23 UTC
Investigating
Our teams are currently investigating email to ticket creation delays for PSA on EU1 and DE1. An update will be posted here as we progress with this investigation.

Thank you for your patience!
Posted Oct 09, 2019 - 10:00 UTC
This incident affected: Autotask PSA (EU1 (English Europe and Asia), German (Deutsch)).