Datto SaaS Protection - Onboarding Errors
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 16:15 UTC
Investigating
SaaS Protection is currently experiencing a temporary interruption to onboarding for new clients. Our Engineering team has identified the problem and actively working on a resolution. An update will be provided shortly regarding an ETA for new client onboarding to be available again. All other aspects of SaaS Protection (Backup, Restore, Export, and Administration) are fully operational.

For more information, please contact our Support team by either creating a support ticket or chatting in via help.datto.com, or calling them at (877) 400-7227.
Posted Jan 13, 2021 - 15:26 UTC
This incident affected: Datto SaaS Protection and Backupify (Backupify SaaS Protection Client Onboarding).