[Datto SaaS Protection] Large delays in receiving initial and incremental backups for Exchange/SharePoint services on use1-saas-p2 and use1-saas-p3
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 17:18 UTC
Update
Delays with initial and incremental backups for Exchange/SharePoint services on the use1-saas-p2 pod have been resolved.

Our Engineering team has identified the root cause for the use1-saas-p3 pod, and the ETA for resolution is March 30th, 2023.

Affected Pods : pod use1-saas-p3

Impact : Customers on use1-saas-p3 may experience delays in receiving initial and incremental backups for their Exchange services.

Unsure of which node or pod you are on? We have a Knowledge Base article to walk you through determining your node or pod: https://saasprotection.datto.com/help/M365/Content/Troubleshooting/General/KB3600004035831.html?Highlight=how%20do%20I%20check%20where%20my%20cloud%20data%20is%20stored

Subscribe to Datto SaaS Protection on the Status Page for up to date information. You can monitor the current status of this issue at https://status.datto.com/
Posted Mar 24, 2023 - 12:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 16, 2023 - 13:01 UTC
Investigating
We are currently aware of a problem where customers on use1-saas-p2 and use1-saas-p3 may experience large delays in receiving initial and incremental backups for their Exchange/SharePoint services.

Our Engineering team is currently investigating this issue. Currently, we do not have an ETA on when a fix will be available.

Affected Pods :
1. pod use1-saas-p2
2. pod use1-saas-p3

Unsure of which node or pod you are on? We have a Knowledge Base article to walk you through determining your node or pod: https://saasprotection.datto.com/help/M365/Content/Troubleshooting/General/KB3600004035831.html?Highlight=how%20do%20I%20check%20where%20my%20cloud%20data%20is%20stored

Subscribe to Datto SaaS Protection on the Status Page for up to date information.

You can monitor the current status of this issue at https://status.datto.com/
Posted Mar 09, 2023 - 15:27 UTC
This incident affected: Datto SaaS Protection (SaaS Protection Backups).