Datto SaaS Protection - SaaS Protection UI Inaccessible
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 13:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2021 - 12:48 UTC
Update
We are continuing to investigate this issue.
Posted Jan 12, 2021 - 12:38 UTC
Investigating
Datto is currently aware of a problem where the SaaS Protection UI is inaccessible for some users.

Our Engineering team has investigated the issue and has identified the reason for the outage.

Currently, we do not have an ETA on when a fix will be available but our Engineering team is actively working on a resolution.

For more information, please contact our Support team by either creating a support ticket or chatting in via help.datto.com, or calling them at (877) 400-7227.
Posted Jan 12, 2021 - 12:38 UTC
This incident affected: Datto SaaS Protection and Backupify (Backupify Backups, Backupify SaaS Console Login, Backupify Seat Management, Backupify SaaS Protection Client Onboarding).