[SaaS Defense] High latency in US cluster
Incident Report for Datto
Postmortem

On 01/25/22, SaaS Defense US region Partners & clients started experience a service interruption which caused high latency during scans, and possibly detection misses.

The root cause for this service interruption was identified to be lack of resources on our cloud infrastructure.

Eventually CPU limitations & network limitations caused our application to be much slower.

Our Engineering team deployed the final fix to correct the problem on 01/26/22 at 20:45 UTC time.

Posted Jan 31, 2022 - 14:09 UTC

Resolved
This incident has been resolved.
Posted Jan 27, 2022 - 13:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2022 - 21:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 26, 2022 - 19:02 UTC
Investigating
We are currently aware of a problem where our US cluster is experiencing high latency.

Our Engineering team is currently investigating this issue.

Currently, we do not have an ETA on when a fix will be available.

You can monitor the current status of this issue at https://status.datto.com/
Posted Jan 26, 2022 - 13:34 UTC