Datto Support Phone Outage
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 18:14 UTC
Update
Monitoring - Our phone system is operational at this time.

The telecom provider reports that the issue is resolved. We continue to monitor.
Posted Sep 28, 2021 - 12:58 UTC
Monitoring
Our phone system is operational at this time.

We are actively engaged with the provider to determine if the issue is fully resolved. We continue to monitor.

If you cannot reach us on our support line, please use chat or open a case on help.datto.com.
Posted Sep 27, 2021 - 23:59 UTC
Identified
We are currently aware of a problem where the Datto Support phones are not connecting successfully to an agent due to a telecom provider outage.

We are actively monitoring the situation and are in touch with the provider.

In the meantime please continue to reach out via chat or by opening a case on help.datto.com.

We will continue to provide updates in short intervals.
Posted Sep 27, 2021 - 20:28 UTC
Investigating
We are currently aware of a problem where the Datto Support phones will ring once and then disconnect.

Our Engineering team is aware of the problem and actively investigating the root-cause

Currently, there is no ETA on when the Datto Support phone system will be restored.

Please bear in mind that you can still utilize the Support Chat function to raise a ticket with our Support team or engage on existing tickets.

You can monitor the current status of this issue at https://status.datto.com/
Posted Sep 27, 2021 - 18:00 UTC
This incident affected: Datto Phones (Support Phones).