Support Phones Outage
Incident Report for Datto
Resolved
Our engineering team has been closely monitoring this problem. The service has been deemed stable. We are now marking this incident as resolved. If you are still experiencing difficulties, please reach out to our Support Team at 877-455-6015. A post-mortem is forthcoming. Thank you for your patience.
Posted Mar 22, 2020 - 18:08 UTC
Investigating
We are currently investigating an issue with our Support Phones due to a power outage. Please contact Datto Technical Support over email at this time.
Posted Mar 22, 2020 - 18:04 UTC
This incident affected: Datto Phones (Support Phones).