Partner Portal Outage
Incident Report for Datto
Resolved
Our engineering team has been closely monitoring this problem. The service has been deemed stable. We are now marking this incident as resolved. If you are still experiencing difficulties, please reach out to our Support Team at 877-455-6015. A post-mortem is forthcoming. Thank you for your patience.
Posted 17 days ago. Jun 30, 2019 - 15:23 UTC
Investigating
We are currently experiencing a disruption with the Partner Portal. We apologize for any inconvenience. We are investigating the root-cause of the problem and will be updating regularly. Please subscribe to receive these regular updates.
Posted 17 days ago. Jun 30, 2019 - 15:06 UTC
This incident affected: Partner Portal.