Datto Phone Support outage
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 21:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2021 - 14:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 12, 2021 - 13:54 UTC
Update
We are continuing to investigate this issue.
Posted Feb 12, 2021 - 13:39 UTC
Investigating
Dear partners,

We are currently experiencing an outage with our internal phone system. While we are working on this issue, we highly encourage partners to contact Datto Support on Chat. You can chat with us via the Support Portal https://auth.datto.com/login or help.datto.com

We apologize for the inconvenience
Posted Feb 12, 2021 - 08:21 UTC
This incident affected: Datto Phones (Support Phones).