Partner Portal Outage
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 13:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 12, 2021 - 20:44 UTC
Update
We are continuing to investigate this issue.
Posted Jul 12, 2021 - 20:25 UTC
Investigating
We are currently aware of a problem where actions within the Partner Portal are responding slowly and or timing out.

Our Engineering team is currently investigating the root cause of the problem.

Currently, there is no ETA on when this problem will be resolved.

You can monitor the current status of this issue at https://status.datto.com/
Posted Jul 12, 2021 - 19:59 UTC
This incident affected: Partner Portal.