PSA - AE2 Zone (WW14) - Outage -Under Investigation
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Jan 11, 2021 - 22:28 UTC
Investigating
Our AE2 zone experienced a brief service interruption. This behavior has been resolved and our teams are continuing to monitor it.

Thank you for your time and patience
Posted Jan 11, 2021 - 22:21 UTC
This incident affected: Autotask PSA (America East 2).