Certificate issues preventing Restores and Agent pairing for DCC and DCMA
Incident Report for Datto
Postmortem

On September 30, 2021, at 2pm UTC, Cloud Continuity for PC’s and Datto Continuity for Microsoft Azure Partners experienced a service interruption which caused failures to pair new agents, and restore existing agents.

The root cause for this service interruption was caused by the expiration of LetsEncrypt's root certificate.

Our Engineering team deployed a fix to correct the problem on September 30, 2021, at 5:43pm UTC.

Posted Oct 12, 2021 - 19:40 UTC

Resolved
Our Engineering team has released a fix that should resolve where Certificate issues were preventing Restores and Agent pairing for Cloud Continuity and Datto Continuity for Microsoft Azure.

Please let us know if the original reported issue reoccurs or has not been fully resolved by replying to this ticket within the next 3 days and we will continue investigating the incident and make sure that the proper parties have been informed. After this time the ticket will be closed and archived.

If you are experiencing a new problem please open a new ticket and our Support team will help to troubleshoot and resolve the new problem.

Once closed; Bear in mind that you will have an additional 7 days to respond to and re-open the ticket.

Thank you,
Posted Sep 30, 2021 - 17:30 UTC