[Datto SaaS Protection] Service Interruption impacting M365 backups
Incident Report for Datto
Resolved
Engineering has been actively working with Microsoft and has identified that the issues we're seeing are related to rolling TLS upgrades within Microsoft 365 that are causing issues with HTTP connections. We are continuing to work with them closely to avoid any future service interruptions as there are additional TLS upgrades planned. For now, the situation has been resolved and backup percentages for the affected Microsoft 365 services will soon return to normal levels.
Posted May 14, 2021 - 02:52 UTC
Update
Engineering is continuing to work closely with Microsoft on this issue. Further updates will be provided as soon as possible.
Posted May 14, 2021 - 00:36 UTC
Identified
SaaS Protection is currently experiencing a service interruption with M365 backups due to intermittent connection issues. Microsoft has notified us that this is due to a configuration issue related to an upgrade being rolled out to their data centers. Further updates will be provided as soon as possible. All other aspects of SaaS Protection (including Restore, Export, and Onboarding) are fully operational.
Posted May 13, 2021 - 21:28 UTC
This incident affected: Datto SaaS Protection (SaaS Protection Backups).