PSA - LON UK zone - Email to ticket creation delay Under Investigation
Incident Report for Datto
Postmortem

Start and End Date/Time (UTC):

08:02 February 12th, 2020 - 14:45 February 12th, 2020

Zone(s) Affected:

UK customers that have their email processor address configured with the @email.autotask.net domain

Root Cause Analysis:

On Wednesday, February 12th, 2020 at approximately 0802 UTC, some partners in the UK zone reported delays in Email processing of up to 30 minutes. After troubleshooting, we discovered a communications issue (packet loss) between datacenters which resulted in an email processing slowdown. The network issue was resolved at approximately 14:45 UTC. We followed up with our network provider, they informed us that while they did not perform any action, they did see that a PeerLink on their network which was previously saturated was no longer experiencing any packet loss. Our vendor was unable to provide any specific details about the root cause of the saturation other than to speculate about the actions of other providers. We have increased resources for our mail cluster in order to decrease email processing time. There have been no further issues observed with this network provider.

Posted Mar 04, 2020 - 13:51 UTC

Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 11:41 UTC
Monitoring
The problem causing the delay has been rectified, all emails should be processing in due course. We continue to monitor the service.
Posted Feb 12, 2020 - 09:14 UTC
Investigating
Our teams are currently investigating reports of email to ticket creation delay for PSA on the London UK zone. The delay is currently estimated at 30 minutes and emails are being processed. Updates will be posted here with the status of this investigation.

Thank you for your patience!
Posted Feb 12, 2020 - 08:55 UTC
This incident affected: Autotask PSA (UK (United Kingdom)).