RMM - All platforms- Alert Data is failing to load on the New UI
Incident Report for Datto
Postmortem

On January 24th, 2022 at 08:15 UTC, Datto Partners on all platforms experienced a service interruption which caused the inability to load Alert Data within the New UI.

The root cause for this service interruption was identified to be a change performed by Amazon to the AWS WAF which resulted in requests being blocked.

The AWS WAF rules were temporarily edited to work around the change and the service was confirmed to be restored January 24th, 2022 at 10:12 UTC.

The following day, January 25th, 2022, Amazon reverted the change they made to the AWS WAF that caused the behavior. The edited AWS WAF rules were reverted back to their original settings.

Posted Feb 22, 2022 - 15:41 UTC

Resolved
This incident has been resolved.
Posted Jan 24, 2022 - 11:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2022 - 10:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 24, 2022 - 10:13 UTC
Update
We are continuing to investigate this issue.
Posted Jan 24, 2022 - 10:09 UTC
Investigating
Our teams are currently investigating an issue with Alert Data loading on the New UI on all platforms.

We apologise for the inconvenience and thank you for your patience!
Posted Jan 24, 2022 - 09:54 UTC
This incident affected: Datto RMM (Pinotage (EU1), Merlot (EU2), Zinfandel (US West), Concord (US East), Syrah (APAC)).