DNA Management Inaccessible
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Oct 19, 2021 - 18:12 UTC
Identified
We are currently aware of a problem where DNA management is inaccessible.

Our Engineering team has identified the issue.
Posted Oct 19, 2021 - 18:03 UTC
This incident affected: Datto Networking (Routers).