EMEA Support Phone Outage
Incident Report for Datto
Resolved
Our engineers have identified and resolved the issue.
Posted Apr 16, 2019 - 11:38 UTC
Update
We are continuing to investigate this issue.
Posted Apr 16, 2019 - 11:30 UTC
Update
We are continuing to investigate this issue.
Posted Apr 16, 2019 - 11:24 UTC
Investigating
We are investigating issues with our EMEA support lines. Our engineers are actively working to resolve the issue.
Posted Apr 16, 2019 - 11:23 UTC
This incident affected: Datto Phones (Support Phones).