Support Phones Outage
Incident Report for Datto
Resolved
Our engineering team has been closely monitoring this problem. The service has been deemed stable. We are now marking this incident as resolved. If you are still experiencing difficulties, please reach out to our Support Team at 877-455-6015. A post-mortem is forthcoming. Thank you for your patience.
Posted Jan 22, 2020 - 07:51 UTC
Investigating
We are experiencing support phone connection problems. We are working to restore service shortly.
Posted Jan 22, 2020 - 07:30 UTC
This incident affected: Datto Phones (Support Phones).