Support Phones
Incident Report for Datto
Resolved
This incident has been resolved.
Posted Mar 22, 2020 - 16:37 UTC
Identified
We are continuing to monitor this outage and have put in a fix for the main line. All partners can reach us by calling the main line: 833-832-4780
Posted Mar 22, 2020 - 15:56 UTC
Investigating
We are experiencing support phone connection problems. We are working to restore service shortly.
Posted Mar 22, 2020 - 11:00 UTC
This incident affected: Datto Phones (Support Phones).