Datto Commerce - Autotask PSA integration outage.
Incident Report for Datto
Postmortem

On 21 April 2021 at 11:44am UTC, our Datto Commerce Engineering Team has noticed an issue with the Datto Commerce - Autotask PSA integration.

The issue has impacted the synchronization engine between Datto Commerce and Autotask PSA: preventing Company and Contact/Quote sync.

The Datto Commerce and Autotask PSA Engineering teams have been working on troubleshooting this issue and the root cause has been identified to be in a recently deployed integration code change. This error has resulted in the requests the integration uses to communicate with Autotask PSA to fail.

A fix has been developed and deployed to resolve the issue at 11:40am UTC on 22nd April 2021.

Posted Apr 22, 2021 - 11:10 UTC

Resolved
The engineering team has worked on and deployed the fix to resolve the issue with the PSA integration. The integration should be fully operational now.

Thank you for your patience while we were working on this issue and we apologise for any inconvenience!
Posted Apr 22, 2021 - 11:00 UTC
Identified
Our Engineers have identified the issue and now working on a fix.

Thank you for the patience and we apologise for the inconvenience!
Posted Apr 22, 2021 - 08:23 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2021 - 07:53 UTC
Investigating
Our engineers are currently investigating an issue with the Datto Commerce to Autotask PSA integration impacting Partners ability to sync information (including: Quotes, Contacts and Sales) between the two platforms.

Other Datto Commerce integrations are unaffected.

We apologise for the inconvenience, further updates will be posted here.
Posted Apr 22, 2021 - 07:52 UTC
This incident affected: Datto Commerce (Integrations).