PSA - (LR, AW, AW2, AE, AE2, AU, ES) - Errors with email ticket creation.
Incident Report for Datto
Postmortem

In the pursuit of improving Datto PSA, we released an update on the 15th of July. Due to a misconfiguration, the update had adversely affected email to ticket processing. The result of which was email processing errors and “bounce backs.” As a response we have put additional checks in place to ensure this does not happen again. If you have any questions please feel free to reach out to our support team. We thank you for your patience, understanding and empathize with any problems this may have caused.

Posted Jul 28, 2020 - 18:30 UTC

Resolved
Our engineers have identified and resolved the root cause of the issue and mail processing has returned to normal across all zones.

Thank you for your patience and apologies for any inconvenience caused.
Posted Jul 16, 2020 - 02:04 UTC
Update
Our engineers are continuing to investigate the issue and have established that the following zones may be impacted: LR, AW, AW2, AE, AE2, AU, ES
Posted Jul 16, 2020 - 00:28 UTC
Investigating
Our engineers are currently investigating reports of "Email service error" and "Inbound email message did not provide a valid recipient address" when attempting to create tickets via email.

We appreciate your patience and will provide an update within the hour.
Posted Jul 15, 2020 - 23:34 UTC
This incident affected: Autotask PSA (Limited Release, America East, America East 2, America West, America West 2, Australia / New Zealand, Spanish (Español)).