Datto Workplace - Azure Active Directory integration failing to authenticate integrated users
Incident Report for Datto
Postmortem

Following the 2021.4.1 release for Datto Workplace (v8.13.2) on 10-November-2021, users experienced an issue which caused Azure Active Directory authentication to Workplace Online and Azure Active Directory synchronisation to fail.

In the release there was a change to the integration with Microsoft Azure AD. The change was related to the deprecation of the previous Microsoft Azure API, and migration to the new Azure AD Graph API. The update went through QA testing as well as testing in a live environment. However there were for some customers configuration differences that caused the failure to surface that had not been caught in the QA phase.

Our Engineering team deployed a fix to correct the problem on 11-November-2021 by 20:00 UTC

Posted Nov 14, 2021 - 13:24 UTC

Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 22:40 UTC
Monitoring
A fix has been implemented on all cells, and we have updated our guide with how to configure the Azure Active Directory Integration with the Microsoft Graph API.

https://workplace.datto.com/managerhelp/Content/3_ONLINE/Configuration/WAAD_Configuration_Supplement.htm
Posted Nov 12, 2021 - 07:10 UTC
Identified
The issue has been identified and the Engineering team has created a fix.

The fix is being rolled out to all cells. We will update this space once the fix is live on all cells and continue monitoring the results and reports.

Thank you for your patience!
Posted Nov 11, 2021 - 17:11 UTC
Update
Our teams continue to investigate issues with the Azure Active Directory integration, where the integration fails to sync changes and authenticate users following the latest Service Update.

Users configured with the Azure SSO integration can successfully authenticate.

We will update this post as new information becomes available. We appreciate your patience!
Posted Nov 11, 2021 - 13:50 UTC
Investigating
Our teams are currently investigating reports of logins failing with Azure Active Directory Integration implementations for Datto Workplace following the latest Service Update.

The issue does not impact users configured for Azure SSO authentication, enabling Azure SSO thus resolves the problem while we investigate and resolve the root cause.

We will update this post as new information becomes available. We appreciate your patience!
Posted Nov 11, 2021 - 12:18 UTC
This incident affected: Datto Workplace (AU5, CA3, EU2, EU4, EU7, EU16, US1, US6, US15).