Datto Store Unavailable
Incident Report for Datto
Resolved
This incident impacting the Datto Store has been resolved.
Posted Jan 18, 2022 - 17:58 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 18, 2022 - 17:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 18, 2022 - 17:27 UTC
Investigating
We are currently aware of a problem accessing the Datto Store. Our team is investigating the issue. At this time we do not have an ETA on when a fix will be available.
Posted Jan 18, 2022 - 15:41 UTC
This incident affected: Datto Store (Product Selector, Check Out, Make a Payment, Subscription Management, Purchase History).