PSA - AE - Reports of inability to log in - Under Investigation
Incident Report for Datto
Resolved
This incident has been resolved.
Posted May 23, 2019 - 00:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2019 - 20:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 22, 2019 - 20:39 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2019 - 20:23 UTC
Investigating
We are currently investigating reports of login issues on the America East zone. An update will be posted here within 30 minutes. Thank you for your patience!
Posted May 22, 2019 - 20:23 UTC
This incident affected: Autotask PSA (America East, America East 2).